using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"idIwant.*?(\d+)";
string input = @"{},\""employees\"":{},\""idIwant\"":{\""2545\"":{\""attributes\"":{\""offset\"":9855,";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}