re = /idIwant.*?(\d+)/
str = '{},\\"employees\\":{},\\"idIwant\\":{\\"2545\\":{\\"attributes\\":{\\"offset\\":9855,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end