const regex = /^(?:Mrs?|Ms|[DE]r)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:Mrs?|Ms|[DE]r)\\.', 'gm')
const str = `Mr. Abc
Mrs.Abc
Ms. Abc
Dr. Abc
Er. Abc`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);