import re
regex = re.compile(r"^(?:Mrs?|Ms|[DE]r)\.", flags=re.MULTILINE)
test_str = ("Mr. Abc\n"
"Mrs.Abc\n"
"Ms. Abc\n"
"Dr. Abc\n"
"Er. Abc")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)