use strict;
my $str = 'Mr. Abc
Mrs.Abc
Ms. Abc
Dr. Abc
Er. Abc';
my $regex = qr/^(?:Mrs?|Ms|[DE]r)\./mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";