#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\([a-z0-9_-]+:)(\((?:[^()]+|(?1))*+\))"
Local $sString = "(image: sky.jpg)" & @CRLF & _
"(image: sky.jpg title: Sky (Issue This) View)" & @CRLF & _
"(link: https://stackoverflow.com text: Stack Overflow)" & @CRLF & _
"(link: https://stackoverflow.com text: Stack Overflow rel=nofollow)" & @CRLF & _
"(video: http://www.youtube.com/watch?v=49Kh1mS4Fhs)" & @CRLF & _
"(vi+deo: http://www.youtube.com/watch?v=49Kh1mS4Fhs)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")