$re = '/(?=\([a-z0-9_-]+:)(\((?:[^()]+|(?1))*+\))/m';
$str = '(image: sky.jpg)
(image: sky.jpg title: Sky (Issue This) View)
(link: https://stackoverflow.com text: Stack Overflow)
(link: https://stackoverflow.com text: Stack Overflow rel=nofollow)
(video: http://www.youtube.com/watch?v=49Kh1mS4Fhs)
(vi+deo: http://www.youtube.com/watch?v=49Kh1mS4Fhs)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);