import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\([a-z0-9_-]+:)(\\((?:[^()]+|(?1))*+\\))";
final String string = "(image: sky.jpg)\n"
+ "(image: sky.jpg title: Sky (Issue This) View)\n"
+ "(link: https://stackoverflow.com text: Stack Overflow)\n"
+ "(link: https://stackoverflow.com text: Stack Overflow rel=nofollow)\n"
+ "(video: http://www.youtube.com/watch?v=49Kh1mS4Fhs)\n"
+ "(vi+deo: http://www.youtube.com/watch?v=49Kh1mS4Fhs)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}