import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:begin|\\G(?!^))(?:(?!end)\\D)+\\K\\d+";
final String string = "11\n"
+ "a\n"
+ "b\n"
+ "13\n"
+ "begin\n"
+ "t\n"
+ "899\n"
+ "y\n"
+ "50\n"
+ "f\n"
+ "end\n"
+ "91\n"
+ "h";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}