re = /(?:begin|\G(?!^))(?:(?!end)\D)+\K\d+/
str = '11
a
b
13
begin
t
899
y
50
f
end
91
h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end