import re
regex = re.compile(r"^(\+?6?01)[0|1|2|3|4|6|7|8|9]\-*[0-9]{7,8}$")
test_str = "0143678890"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")