const regex = /^(?=.{2,16}$)(?=[^\d\n]*\d)[a-zA-Z\d]+(?:[ -][a-zA-Z\d]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{2,16}$)(?=[^\\d\\n]*\\d)[a-zA-Z\\d]+(?:[ -][a-zA-Z\\d]+)?$', 'gm')
const str = `test one
test 2two
test3 three222
3test-4four
-test
test-d f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}