$re = '/^(?=.{2,16}$)(?=[^\d\n]*\d)[a-zA-Z\d]+(?:[ -][a-zA-Z\d]+)?$/m';
$str = 'test one
test 2two
test3 three222
3test-4four
-test
test-d f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);