re = /^(?=.{2,16}$)(?=[^\d\n]*\d)[a-zA-Z\d]+(?:[ -][a-zA-Z\d]+)?$/m
str = 'test one
test 2two
test3 three222
3test-4four
-test
test-d f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end