import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(CASE\\s+WHEN.*?END)";
final String string = "iduser + CaSe WhEn (\"end\") = 0 THEN 'CASE WHEN' ELSE 'END' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}