#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(CASE\s+WHEN.*?(?<!['"])END)"
Local $sString = "iduser + CaSe WhEn ("end") = 0 THEN 'CASE WHEN' ELSE 'END' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")