using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(CASE\s+WHEN.*?(?<!['""])END)";
string input = @"iduser + CaSe WhEn (""end"") = 0 THEN 'CASE WHEN' ELSE 'END' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}