using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[([^][S]++(?:S(?!PACE)|[^][S]+)*+)SPACE([^][]++)\]\]";
string input = @".. [[ ..text(not to cut).. [[wordoneSPACE**wordtwo**]] ..moretext..
..text.. [[wordoneSPACE**wordtwo**]] ..moretext..";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}