$re = '/\[\[([^][S]++(?:S(?!PACE)|[^][S]+)*+)SPACE([^][]++)\]\]/m';
$str = '.. [[ ..text(not to cut).. [[wordoneSPACE**wordtwo**]] ..moretext..
..text.. [[wordoneSPACE**wordtwo**]] ..moretext..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);