re = /\[\[([^][S]++(?:S(?!PACE)|[^][S]+)*+)SPACE([^][]++)\]\]/m
str = '.. [[ ..text(not to cut).. [[wordoneSPACE**wordtwo**]] ..moretext..
..text.. [[wordoneSPACE**wordtwo**]] ..moretext..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end