const regex = new RegExp('(?<=“)[\\s\\S]+?(?=”)', '')
const str = `“Don't cry because it's over,
smile because it happened.”
―`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}