$re = '/(?<=“)[\s\S]+?(?=”)/';
$str = '“Don\'t cry because it\'s over,
smile because it happened.”
―';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);