re = /(?<=“)[\s\S]+?(?=”)/
str = '“Don\'t cry because it\'s over,
smile because it happened.”
―'
# Print the match result
str.match(re) do |match|
puts match.to_s
end