# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\#{4}\s{1}[\d\D].*?[:]\s{2})\n\n(>[\d\D].*?\s{2})\n([\d\D].*?\s{2})/$1\n\n$2\n> $3\n> /gm;t' <<< "#### <u>Author name</u> writes in his 'Title of some Book/Essay/Article':
> First sentence with soft line breaks at the end.
Second sentence.
Third sentence.
Any number of sentences if there are any will follow — all need to be in quote blocks.
<Some other text not belonging to above author comes after empty line>.
"