const regex = /(^\#{4}\s{1}[\d\D].*?[:]\s{2})\n\n(>[\d\D].*?\s{2})\n([\d\D].*?\s{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\#{4}\\s{1}[\\d\\D].*?[:]\\s{2})\\n\\n(>[\\d\\D].*?\\s{2})\\n([\\d\\D].*?\\s{2})', 'gm')
const str = `#### <u>Author name</u> writes in his 'Title of some Book/Essay/Article':
> First sentence with soft line breaks at the end.
Second sentence.
Third sentence.
Any number of sentences if there are any will follow — all need to be in quote blocks.
<Some other text not belonging to above author comes after empty line>.
`;
const subst = `$1\n\n$2\n> $3\n> `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);