import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\#{4}\\s{1}[\\d\\D].*?[:]\\s{2})\\n\\n(>[\\d\\D].*?\\s{2})\\n([\\d\\D].*?\\s{2})";
final String string = "#### <u>Author name</u> writes in his 'Title of some Book/Essay/Article': \n\n"
+ "> First sentence with soft line breaks at the end. \n"
+ "Second sentence. \n"
+ "Third sentence. \n"
+ "Any number of sentences if there are any will follow — all need to be in quote blocks. \n\n"
+ "<Some other text not belonging to above author comes after empty line>. \n\n";
final String subst = "$1\\n\\n$2\\n> $3\\n> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}