using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/|\.)(new|нов|yjd|туц)\S* (\S*) (.*)";
string input = @"/new contact Raul Duke
/new contact
/new";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}