package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/|\.)(new|нов|yjd|туц)\S* (\S*) (.*)`)
var str = `/new contact Raul Duke
/new contact
/new`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}