using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&redirect_uri=\S+?localhost\K%[^%]+";
string substitution = @"";
string input = @"https://www.facebook.com/v2.5/dialog/oauth?client_id=*****&state=*****&response_type=code&sdk=php-sdk-5.1.2&redirect_uri=http%3A%2F%2Flocalhost%3A8888%2Ffacebook%2Flink&scope=email%2Cuser_birthday%2Cuser_photos";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}