import re
regex = re.compile(r"^(?:[0-9A-Fa-f]+\s+){1,4}", flags=re.MULTILINE)
test_str = ("A92 6100 011E Bsr P6\n"
"A96 43EE 003A Lea.L $3A(A6), A1\n"
"A9A 6100 013E Bsr P8\n"
"A9E 6608 BNE.B L90\n"
"AA0 4E91 Jsr (A1)\n"
"AA2 70F5 MoveQ.L #$-B, D0\n"
"AA4 6100 010C Bsr P6\n"
"AA8 43F8 0AD8 L90: Lea.L (SysResName), A1\n"
"AAC 76FF MoveQ.L #$-1, D3\n"
"AAE 6100 012C Bsr P9\n"
"AB2 6600 0004 BNE L91\n"
"AB6 4E91 Jsr (A1)\n"
"AB8 21F8 02A6 02B2 L91: Move.L (SysZone), (RAMBase)\n"
"ABE 700C MoveQ.L #$C, D0\n"
"AC0 A722 _NewHandleSysClear\n"
"AC2 21C8 0AEC Move.L A0, (AppParmHandle)\n"
"AC6 A02C _InitApplZone\n"
"AC8 A04F _RDrvrInstall\n"
"ACA 2F05 Move.L D5, -(A7)")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)