import Foundation
let pattern = #"^(?:[0-9A-Fa-f]+\s+){1,4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
A92 6100 011E Bsr P6
A96 43EE 003A Lea.L $3A(A6), A1
A9A 6100 013E Bsr P8
A9E 6608 BNE.B L90
AA0 4E91 Jsr (A1)
AA2 70F5 MoveQ.L #$-B, D0
AA4 6100 010C Bsr P6
AA8 43F8 0AD8 L90: Lea.L (SysResName), A1
AAC 76FF MoveQ.L #$-1, D3
AAE 6100 012C Bsr P9
AB2 6600 0004 BNE L91
AB6 4E91 Jsr (A1)
AB8 21F8 02A6 02B2 L91: Move.L (SysZone), (RAMBase)
ABE 700C MoveQ.L #$C, D0
AC0 A722 _NewHandleSysClear
AC2 21C8 0AEC Move.L A0, (AppParmHandle)
AC6 A02C _InitApplZone
AC8 A04F _RDrvrInstall
ACA 2F05 Move.L D5, -(A7)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)