package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]*(?:[#?$%][a-zA-Z0-9]*)?$`)
var str = `
aa123#212334
aa123#212334?
aa123#212334
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}