re = /^[a-zA-Z0-9]*(?:[#?$%][a-zA-Z0-9]*)?$/m
str = '
aa123#212334
aa123#212334?
aa123#212334
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end