$re = '/^[a-zA-Z0-9]*(?:[#?$%][a-zA-Z0-9]*)?$/m';
$str = '
aa123#212334
aa123#212334?
aa123#212334
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);