import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}(_(?!$)(\\d{1,2}[A-Za-z]{1,2})*\\d{0,2})?$";
final String string = "1\n"
+ "1_1\n"
+ "1_1a\n"
+ "1_1a1\n"
+ "1_11a1aa\n\n"
+ "A\n"
+ "111\n"
+ "11A\n"
+ "1_\n"
+ "1_111\n"
+ "1_a\n"
+ "1_1aaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}