re = /^\d{1,2}(_(?!$)(\d{1,2}[A-Za-z]{1,2})*\d{0,2})?$/m
str = '1
1_1
1_1a
1_1a1
1_11a1aa
A
111
11A
1_
1_111
1_a
1_1aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end