use strict;
my $str = '1
1_1
1_1a
1_1a1
1_11a1aa
A
111
11A
1_
1_111
1_a
1_1aaa';
my $regex = qr/^\d{1,2}(_(?!$)(\d{1,2}[A-Za-z]{1,2})*\d{0,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}