package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}(?1){2}\d{2,3}$`)
var str = `A555BA77
А555Вb65
t333yx179
а001аа177
АВЕКМНОРСТУХ
ABEKMHOPCTYX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}