re = /^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}(?1){2}\d{2,3}$/mi
str = 'A555BA77
А555Вb65
t333yx179
а001аа177
АВЕКМНОРСТУХ
ABEKMHOPCTYX
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end