// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}(?1){2}\d{2,3}$").unwrap();
let string = "A555BA77
А555Вb65
t333yx179
а001аа177
АВЕКМНОРСТУХ
ABEKMHOPCTYX
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}