re = /^[[:xdigit:]]{8}(?:\-[[:xdigit:]]{4}){3}\-[[:xdigit:]]{12}$/m
str = '2f106095-bd0b-4476-9747-ac4808d42ddf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end