package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/(healthyawards)\/??$`)
var str = `http://localhost:7003/u/global/gadgets/healthyAwardsClub.jsp
http://localhost:7003/healthyawards
http://localhost:7003/healthyawards/
http://localhost:7003/u/global/gadgets/healthyawards/healthyAwardsClub.jsp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}