const regex = /^\/(healthyawards)\/??$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(healthyawards)\\\/??$', 'g')
const str = `http://localhost:7003/u/global/gadgets/healthyAwardsClub.jsp
http://localhost:7003/healthyawards
http://localhost:7003/healthyawards/
http://localhost:7003/u/global/gadgets/healthyawards/healthyAwardsClub.jsp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}