package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(interface)\s+([^!]+)`)
var str = `!
interface TenGigabitEthernet 1/49
description Uplink
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/50
no ip address
shutdown
!
interface TenGigabitEthernet 1/51
no ip address
shutdown
!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}