import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(interface)\\s+([^!]+)";
final String string = "!\n"
+ "interface TenGigabitEthernet 1/49\n"
+ " description Uplink\n"
+ " no ip address\n"
+ " switchport\n"
+ " no shutdown\n"
+ "!\n"
+ "interface TenGigabitEthernet 1/50\n"
+ " no ip address\n"
+ " shutdown\n"
+ "!\n"
+ "interface TenGigabitEthernet 1/51\n"
+ " no ip address\n"
+ " shutdown\n"
+ "!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}