re = /(interface)\s+([^!]+)/m
str = '!
interface TenGigabitEthernet 1/49
description Uplink
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/50
no ip address
shutdown
!
interface TenGigabitEthernet 1/51
no ip address
shutdown
!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end