#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(.+?\))(?=\s)"
Local $sString = "Công ty (a(df)ad) hữu hạn (TNHH))))sdfsdfsd)))))" & @CRLF & _
"" & @CRLF & _
"Công ty (((CT))) trách nhiệm hữu hạn (TNHH) " & @CRLF & _
"" & @CRLF & _
"Công ty (a(df)ad) hữu hạn (TNHH)" & @CRLF & _
"" & @CRLF & _
"Công ty ((bbbbb(CTrrrr)dddđ)) trách nhiệm hữu hạn (TN(((((((HH) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")