package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_(.*)\.`)
var str = `1782_eqjobs.hostname -> eqjobs
519_fid_quant.hostname -> fid_quant`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}