$re = '/_(.*)\./m';
$str = '1782_eqjobs.hostname -> eqjobs
519_fid_quant.hostname -> fid_quant';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);