re = /_(.*)\./m
str = '1782_eqjobs.hostname -> eqjobs
519_fid_quant.hostname -> fid_quant'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end